Rpw : Rowperfect for Windows

developed by Row-Ware, The Netherlands

Manual 1.1.3.1 rev 1 - September 2012

Rpw : Rowperfect for Windows

© 2004-2012, Row-Ware

Contact information
Rowperfect Pty Ltd
Australia
website

http://www.rowperfect.com/

Row-Ware – software development
The Netherlands
website
e-mail

http://www.row-ware.com/
info@row-ware.com

Copyright
The software Rpw : Rowperfect for Windows and this manual are © 2004-2012 Row-Ware, The
Netherlands.

Disclaimer
This software is provided 'as-is', without any express or implied warranty. In no event will the
author be held liable for any damages arising from the use of this software.

The revision – see cover page – of this document voids any previous revisions.

-2-

Rpw : Rowperfect for Windows

© 2004-2012, Row-Ware

About this manual
This is the manual for Rowperfect for Windows (or Rpw for short). Rpw is a MS Windows based
successor of the original CARE/DOS Rowperfect software. It runs on all MS Windows versions
currently available, including – but not limited to – Windows 98, XP and Vista. It is compatible
with most USB Serial Adapters, allowing modern PCs without a Com port to be used with the
Rowperfect rowing simulator.
This manual consists of the following sections:
A
Quick start guide
This section gives a user enough information to get Rpw up and running and to use the most
common parts of the programme, following a step-by-step approach.
B
Reference manual
All aspects of the programme are covered in the Reference manual. It describes each menu
option and screen in detail, and could be seen as a “dictionary”. One chapter is dedicated to
former users of the DOS software from Rowperfect (CARE.EXE).
C
Frequently Asked Questions
The Frequently Asked Questions list can be used as a shortcut to information available elsewhere
in this manual.
D
Appendices
The appendices contain the table of contents and lists of figures and tables.
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Quick start guide

The most common tasks performed in Rpw are recording a training session, reviewing a training
session as a whole, and reviewing a training session stroke-by-stroke. These tasks are described
below, step-by-step.
For more details on the windows described in this Quick start guide, please consult the
Reference manual (section B, page 8).

A.1. Before we start : Installation
When Rpw will be used for recording data, the Rowperfect PC interface needs to be mounted on
the Rowperfect rowing simulator (next paragraph), or the MkIV monitor needs to be set-up
(paragraph A.1.1). When Rpw will be used for “off-line” analysis only, this is not necessary, and
only the software set-up is needed. Software installation is explained in paragraph A.1.3.

A.1.1. Hardware – PC interface
The interface is a small black box (75x57x25 mm) with a small white cylinder protruding from it
(the sensor). The sensor is sensitive towards magnetic fields. Its active spot is very small, and is
situated in the centre of the extremity of the sensor. For proper functioning of the interface it is
essential that the active spot of the sensor is positioned on exactly the same circle as the
magnets in the flywheel that activate the sensor. The distance between sensor and flywheel
should be between 1 and 2 mm.
The interface comes with two mounting brackets. To correctly place the sensor and interface
into the right position proceed as follows (if you are aligning the sensor for the first time it may
help to lay the rowing simulator very gently on its flywheel side, which makes it easier to see
the magnets in the flywheel) :

Figure 1 - Interface set-up

Unscrew the screws in both brackets until flush with the inside of the bracket. Hook the two
brackets with their bent rims pointing towards each other, under the lower rims of the main
frame. Take the interface, put it with the sensor side pointing towards the flywheel and to the
main shaft, and insert the interface between the two brackets. Pushing both brackets firmly
around the interface, slide the interface into position such that the magnets pass directly under
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the centre of the sensor. Make sure the distance between the top of the sensor and the flywheel
surface is between 1 and 2 mm, and the interface body is parallel to the flywheel. Then tighten
gently the four screws to fix the brackets, and thus the interface, in the proper position. Put the
rowing simulator upright again.

A.1.2. Hardware – MkIV monitor
For the MkIV monitor, the signal needed for Rpw is generated by the rotating magnet on the fly
wheel; no alignment is necessary. Simply ensure the MkIV Monitor is mounted properly and
connected to the sensor via the fan icon. (see Figure 4).
Note : The term “interface” will be used for the remainder of this manual. It corresponds to
either a Rowperfect PC interface or MkIV monitor.

A.1.3. Software
To install Rpw for the first time on a PC, or to upgrade an existing installation of Rpw, take the
following steps:
 Download the latest installer from our website http://www.row-ware.com/rpw/ and save
the file rpwNNNN.exe (where NNNN reflects the version number, e.g. “rpw1120.exe”
contains “Rpw 1.1.2.0”) on your desktop.
 Double-click rpwNNNN.exe
 You can change the default destination folder Rpw will be installed in. If needed, please do
so here. After reading and agreeing with the “Read me / License” text, click Install.
 The files will be copied to the destination folder, and a shortcut in the Windows Start menu
will be added. Also, Rpw compatible file types (*.STG, *.STR, *.MKS, *.MKR and *.MKI files)
will automatically be associated with Rpw. To open such a file, just double-click it in the
Windows Explorer.
They can be recognised by a Rpw icon (

or

).

A.1.4. Calibration
Because the flywheels of two Rowperfects are not identical, they are engraved with a
calibration factor. The default calibration factor build into Rpw can be replaced by the number
found on the flywheel. To do so, follow these steps:
 Locate the file RPW.INI in the folder (My) Documents\Row-Ware\Rpw .
 Double click the file to open it.
 Add a line “Inertia=XXXX” in the RPW.INI file in the [Row] section, where the X-es
correspond to the 3rd through 6th digit behind the decimal point of the factor on the
flywheel of the Rowperfect unit concerned. (E.g. for a factor on the flywheel of 0.108867,
the line should read “Inertia=8867”, but then without the quotes).
 Save the file and (re-)start Rpw.

A.1.5. Test interface
To ensure the sensor is positioned correctly and detected accordingly, take the following steps:
 Connect the DB-9 plug of the interface cable to a Com port (or USB Serial Adapter), and the
RJ-45 plug to the bigger one of the two sockets on the PC interface or any one of the sockets
labelled COM on the MkIV monitor
 (Install and) start Rpw
 Click [OK] in the “New row window” dialogue. The dialogue disappears.
 Press [Space] in the “Row” window.
 In the “Connect” dialogue, click on the [Search] button. The software will try to detect an
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interface connected to the PC. If one is found, a message appears and the Source option will
be set to the Com port number found. To check if all four magnets are detected, click the
[Test] button, and give a gently swing to the flywheel. A regular beep will be heard every
time a magnet passes the sensor.

Figure 2 - DB-9 plug

Figure 3 - PC interface

Figure 4 - MkIV

Figure 5 - Connect
dialogue

A.2. Record a training session : Row window
To record a training session, follow these steps. Make sure the PC interface or MkIV is properly
set-up and connected to the PC.
 Start Rpw. A dialogue “New row window” appears, asking for information about the rower.
Here either enter the data needed, or open a previously saved User File file.
 When finished, click [OK], and the Row window is displayed.
 This window contains two charts (left: Force curve of current stroke; right: Stroke history of
all strokes) and 8 parameter cells at the bottom. All these items (charts and cells) can be
adjusted by right-clicking on them.
 By default, a training session is set to 2km countdown. To modify this, click the Training
button ( ) on the toolbar (or press [F6], or select “Training” from the “View” menu). When
the workout has been modified, click the Row button ( ) on the toolbar (or select “Row”
from the “View” menu, or press [Ctrl] + [R]) to switch back to the Row window.
 In the lower left-hand corner, click [Connect] (or press [Space]) to make a connection to the
interface.
 A dialogue “Connect” appears, asking for details about the interface. Select the appropriate
Com port or choose “Demo” and click [OK].
 Start rowing or watch the demo.
 To cancel or to interrupt a training session, click on the [Disconnect] button (or press
[Space]).
 When you have completed your training session, switch to the training window by clicking on
the Training button ( ) on the toolbar (or press [F6], or select “Training” from the “View”
menu).
 The training window appears, showing results and giving the opportunity to add some extra
information to this training session on the General tab. When finished, click the Save button
( ) on the toolbar (or press [Ctrl] + [S], or select “Save” from the “File” menu), to save the
training session to disk.
Note: Training sessions can be saved from within the Row window as well. It is not necessary to
switch to the training window just for saving; it is, however, to add the extra training
information.
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A.3. Review a training session : Stroke data window
A training session can be reviewed by following these steps:
 Start Rpw and click [Cancel] in the “New row window” dialogue.
 Open a file by clicking the Open button ( ) on the toolbar (or press [F9], or select “Open...”
from the “File” menu).
 Click on the Stroke data button ( ) on the toolbar, or select “Stroke data” from the
“Analyse” menu, to open the Stroke data window.
 Set X (bottom), Y (left) and Z (right) axes as needed, by selecting the appropriate parameter
on the right-hand side of the window.
 To compare this training session with another, just open another file.
 Zoom in on the chart, by selecting a rectangle. To do so, click on the chart with the left
mouse button, drag the mouse to the bottom and right, and let go of the mouse button.
 Move the chart, by right-clicking it and moving the mouse. When finished, let go of the
mouse button.
 Reset a chart by selecting a rectangle from bottom-right to top-left.

A.4. Review a training session stroke-by-stroke : Force curves window
To analyse force curves, take these steps:
 Start Rpw and click [Cancel] in the “New row window” dialogue.
 Open a file by clicking the Open button ( ) on the toolbar (or press [F9], or select “Open...”
from the “File” menu).
 Click on the Force curves button ( ) on the toolbar, or select “Force curves” from the
“Analyse” menu, to open the Force curves window.
 Click the training session in the list on the right, and use the “VCR” buttons (
) to
view the next or previous stroke. The “Play” button shows the force curves as an animation.
The data area at the bottom of the screen is updated for every stroke.
 To compare this training session with another, just open another file.
 Scale the force curves by force (vertical) or length (horizontal), for better comparison.
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Reference manual

This section presents a detailed description of all the aspects of Rpw. It starts with some
common user interface features that apply to (almost) every window in the programme, and
then addresses all windows, dialogues and menu-items one by one.

B.1. Standard user interface features
To people used to working with MS Windows and MS Office, Rpw will have a familiar look and
feel. The image below shows a number of standard window items:

Figure 6 - Standard window items









The blue bar on the top stating “Rpw : Rowperfect for Windows” is called the (Main) Title
bar.
The second “line” is the Menu bar, with common items like “File”, “Edit” and “Help”.
Menu items can have Shortcuts, being key(-combinations) to activate the item by pressing
the corresponding key(s) and without using the mouse. Shortcuts are shown next to a menu
item, e.g. the “Row” window can be opened by pressing the “Ctrl” and “R” keys
simultaneously.
The images on the third line are called the toolbar. The buttons shown here are also visible
in one of the menus. Items that can not be used at the time are greyed out (dimmed). Rightclicking the toolbar allows you to hide buttons associated with a specific menu.
Hovering the mouse over an item on the screen and holding it still for a few seconds, will
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show a Hint (or Tool tip) near the mouse pointer. Shortcuts are also shown in hints.
The bottom is called the Status bar. It contains the programme version on the left, and –
when available – extra information on the item the mouse points at.
On several locations throughout the software, clicking with the right mouse button will show
a Pop-up menu, from which specific actions can be selected.

Both analysis windows in Rpw have a common
layout, and consist of three areas:
1. On the top-left, there’s a Chart.
2. The Training sessions list can be found in the
top-right. A training session can be
temporarily switched on and off by
(un-)checking the check-box in front of it.
“Checked” training sessions are called
“Active”. To change the colour of a training
session and corresponding graph in the chart,
double click the name in the training sessions
list. This will bring up the Chart options
dialogue, as shown in Figure 7. Alternatively,
right click for the pop-up menu.
3. The Data area is visible at the bottom.
Columns can be re-sized by dragging (clicking Figure 7 - Chart options
with the left mouse button and holding it down) the line between two columns. Right click
for a pop-up menu that allows for hiding or showing columns and copy the data to the
clipboard. From there, they can be pasted in – for example – your favourite word processor
or spreadsheet application. An example of this is given in paragraph B.14.
The width of the list of training sessions and the height of the data area can be changed by
dragging the Splitter (thick grey line) next / above the area.
All charts in Rpw have these common options:
 To zoom in on a part of a chart, “draw” a window from top-left to bottom-right by clicking
with the left mouse button.
 To move a chart, right-click it and drag the chart.
 To reset a chart to it’s original position / zoom, “draw” a window from bottom-right to topleft.
When Rpw is running, the Windows screen saver and energy saver are blocked, to prevent
problems when recording a training session.
Most of the customizations made in Rpw (e.g. data area columns in the “Stroke data” window,
parameter cells in the “Row” window) are automatically saved upon exiting the programme, to
be re-used the next time the programme is started.
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B.2. Training
All data associated with a training session are visible in a training window. A training window
consists of two tab pages:

B.2.1. Training - General
This tab page contains information about the name of the athlete, date and time of recording
and some extra information like type of training session. The lists of the Name, Description,
Type and Event fields are stored for future reference, so it's not necessary to type common
values here over and over again: just select them from the list. There’s also a Note field to add
text that can’t be categorised, e.g. excuses ... .

Figure 8 - Training general

The asterisks (*) next to the group-box captions (“Training”, “Recording” and so on) indicate the
training session data have been changed, and might need to be saved.
Every training session can have its own colour in the various charts available in Rpw. Set the
colour and line type by clicking the [Options] button, or double-clicking a name in a training
session list (see B.1).
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B.2.2. Training - Workout
The Workout page contains the User settings (Weight and training definition) and training
results. The data shown in User settings can only be modified in new training sessions (see B.3)
and User Files. The values shown in “Totals”, “Averages” and “Intervals” are calculated, and
cannot be modified manually.

Figure 9 - Training workout

To change a value in the “User” group-box, simply click on it. This will result in either a pop-up
menu from which you can choose a parameter (e.g. Session limit), or an edit-box to enter the
required value (e.g. Weight). Press [Tab] to store a value.
The type of training session to be performed can be chosen by giving a certain amount of work
to do or by indicating a certain intensity. The amount of work can be expressed in terms of
strokes, energy, distance or time. The chosen parameter then is counted down from the
limitation value down to zero. At the end of the session the results as shown in the “Totals” and
“Averages” group-boxes are displayed (see Figure 13).
If the option intervals is chosen, the number of intervals, and the units in which the intervals are
going to be counted down – with separate values for the work and rest period - can be selected.
Note: Always choose the number of intervals one higher than the number to be actually rowed.
Data shown in the Intervals area can be copied to the clipboard by clicking on it with the right
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mouse button. To set which columns to display, right-click for a pop-up menu and select the
appropriate option.
To re-set a previously recorded training session, which results in losing all recorded data but
keeping all workout settings, can be done by clicking on the [Reset] button.

B.3. File – New
To create a new, empty training session (to store as a User file, for example), click the New
button ( ) on the toolbar, select “New” from the “File” menu or press [Ctrl] + [N]. An empty
training window appears, which can be filled in as needed. To change a user setting on the
Workout tab, just click on it.
This “Empty” file already has some pre-defined settings. To set these “New training session
defaults”, store a User File with the name “rpw.stg” in the folder (My) Documents\RowWare\Rpw .

B.4. File – Open
To open an existing Rpw compatible file, click the Open button ( ) on the toolbar, select “Open
…” from the “File” menu or press [Ctrl]+[O]. A standard “Open file” dialogue appears. Here one
or two files can be selected to open simultaneously.
Opening files can be done in a number of ways, besides using the toolbar or the “Open …” option
from the “File” menu:
 By dragging one or more files from the Windows Explorer or Windows Desktop on a Rpw icon
 By dragging one or more files from the Windows Explorer or Windows Desktop on a running
copy of Rpw
 By using the command line parameters (see B.20) specifying one or more files to open
automatically at programme start-up. This is especially handy for opening User files to
record a training session.
Names of files that have been opened, are added automatically to the bottom of the “File”
menu, up to a maximum of 10, in a recently used file list. These files can now be easily reopened by selecting them from this list, instead of going through the “Open file” dialogue.
Once files are opened, the analysis can begin.

B.5. File – Close
The option “Close” in the “File” menu closes the active window, regardless of it’s origin. For
“Row” and “Training” windows, a confirmation dialogue will be presented asking if the modified
data can be discarded. When this data needs to be saved, click [Cancel] and save the data by
using either the “Save” or “Save as…” option from the “File” menu (see B.6 and B.7).

B.6. File – Save
To save a new training session, or an existing training session under the same name as it has
been opened, switch to the training window and click the Save button ( ) on the toolbar,
choose “Save” from the “File” menu or press [Ctrl] + [S]. For a new training session, the Export
training session dialogue will be shown (see B.7).

B.7. File – Save As
To save a training session under a different name, or as a different type of file, use the Save As
option. Click the Save As button on the toolbar or select “Save As …” from the “File” menu.
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Alternatively, press [Ctrl]+[Alt]+[S]. This will bring up the Export training session dialogue.
Here a different path, name and / or file-type for the training session can be chosen.
Note: Only STG files can contain all data associated with a training session. The recording
information from the Workout tab is NOT saved in User files (*.INI).

B.8. File – Save chart
When a chart is visible, the Save chart option can be used to save the current window to a BMP
file. To do so, click the Save chart button ( ) on the toolbar, or choose “Save chart…” from the
“File” menu. The background will temporarily be set to white, so the screen might flicker for a
moment. A dialogue titled “Save chart as file” will be shown to enable choosing the folder and
name for the file.

B.9. File – Exit
To exit Rpw, choose “Exit” in the “File” menu, or click the Exit button ( ) on the toolbar. The
programme can also be closed by pressing [Alt] + [F4], or clicking on the cross button in the topright corner of the window.
When closing Rpw, all custom made modifications (chart axes, column sizes, parameter cells
etc.) are saved to be re-used when Rpw is run again.

B.10. Edit menu
Rpw comes with a standard Edit menu, with the usual options:
 Cut ( ). Cuts the selected text and places it on the clipboard. Shortcut [Ctrl] + [X]
 Copy ( ). Copies the selected text and places it on the clipboard. Shortcut [Ctrl] + [C]
 Paste ( ). Pastes the text on the clipboard at the current position, Shortcut [Ctrl] + [V]
 Find. Opens the Find dialogue to search for text within the current field. Shortcut [Ctrl] + [F]
Using the “Copy chart” option in the Edit menu, or clicking the Copy chart button ( ) on the
toolbar, will copy the current window contents to the clipboard as an image. From the
clipboard, the chart can then easily be pasted in, for example, MS Wordpad as shown below:
• Open an analysis window and select the “Copy chart” option from the “Edit” menu.
• Open MS Wordpad, and place the cursor on the position the chart should be inserted.
• choose “Paste” from the “Edit” menu in MS Wordpad (or press [Ctrl] + [V]) to paste the chart.

Figure 11 - Copy chart (MS Wordpad)

Figure 10 - Copy chart (Rpw)
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B.11. View – Row
To record a training session, click the Row button ( ) on the toolbar (or select “Row” from the
“View” menu, or press [Ctrl] + [R]). The “New Row Window” dialogue appears. Make the
appropriate settings, or load a User file from disk, and click [OK]. Now an “empty” Row window
opens. To connect to the interface, click the [Connect] button, or press [Space].

B.11.1.Row – Connect
In the “Connect” dialogue, specify which source to use. Rpw comes with demo data built-in, to
test the software without an interface. To search all Com ports for presence of an interface,
click the [Search] button.
To test whether the selected source is working properly, click the [Test] button. It will sound a
beep every time a magnet in the flywheel moves past the sensor, or, when it’s not turning
approximately every second. When the [Test] button is clicked, four numbers appear at the
bottom of the dialogue. These numbers indicate sensor detection accuracy. To verify sensor
detection, the flywheel must be spinning. The numbers shown there are not (really) relevant,
but they should be more or less stable. When they vary much, there is some problem detecting
all magnets and/or reading the interface data at all.
When the “Connect” dialogue is closed by using the [OK] button, Rpw is ready for action and will
begin recording when the flywheel of the rowing simulator starts spinning. In the lower right
corner of the window, a little clock indicates the time since the connection with the interface
has started.

B.11.2.Row – Interface protocol
Rpw will only accept data from a Rpw compatible PC interface or MkIV monitor. When
connected to an old-style (CARE/DOS) PC interface, an error will be displayed.
Existing PC interfaces can be re-programmed to work with Rpw – please contact your Rowperfect
agent for details.
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B.11.3.Row – window
Figure 12 shows the “Row” window in Rpw:

Figure 12 - Standard row window

The caption of the button in the lower left corner of the window changes, depending on the
state the programme is in. When the interface is not detected – when Rpw has just been
started, for example – the caption says “Connect”. Click it to open the Connect dialogue as
stated above. When connected, the training session will be re-set (previously recorded data will
be lost) and the caption of the button will changed to “Pause”, as in Figure 12. Clicking this will
interrupt the training session and prompt for pausing.
To disconnect from the interface, choose [Yes]. The training session will be aborted, and the
button caption set to “Connect” again. If [No] is clicked. The training session will be paused,
and the caption changed to “Continue”.
The row window consists of 3 areas:
1. Force curve chart on the top left.
Right click on the chart to enable/disable the reference curve(s) – the curves currently
visible in the Force curves window – or the previous stroke.
2. History / Stroke data chart on the top right.
Right click on the chart to set the X, Y and/or Z axis.
3. Data area at the bottom.
Right-click on a parameter cell to choose which data item to show here.
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When a training session is finished, the Results dialogue is
displayed, as shown in Figure 13.

Figure 13 - Results dialogue

B.11.4.Row – Performance issues
Running Rpw on older hardware, with limited processor and/or memory capacity (typically
computers with Windows 98-Me), can result in badly updated charts in the “Row” window,
especially with long sessions (20 minutes and more). To address this, users can switch off the
data chart on the right by right-clicking it, and selecting “Empty”. Alternatively, one can set-up
the programme to just show the last x strokes, in stead of the whole training session. To do so,
follow these steps:
 Locate the file RPW.INI in the folder (My) Documents\Row-Ware\Rpw .
 Double click the file to open it.
 Add a line “DataRange=X” in the RPW.INI file in the [Row] section, where the X denotes the
number of strokes to plot. The minimum is 5, the maximum is 32000. (E.g. to limit the
number of strokes in the chart to 10, the line should read “DataRange=10”, but then without
the quotes).
 Save the file and (re-)start Rpw.

B.12. View – Training
Click the Training button ( ) on the toolbar (or select “Training” from the “View” menu, or
press [Ctrl]+[T]), to switch to the training window belonging to the Row window. Therefore, this
option is only available if a Row window is already present. The Training window is explained in
detail in B.2.
To switch to another window, alternatively press [Ctrl] + [F6].
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B.13. View – Other menu items
Rpw can be set to full screen (or reset to a normal window), by selecting the corresponding
option from the “View” menu. A tick mark in front of the menu item indicates its current state.
In full screen mode, the main title bar is no longer visible.
Note: Only switch from or to full screen mode when there are no windows open at the time.
Most of the buttons, lists etc. in Rpw will show a hint if the mouse pointer pauses while hovering
over them. If required, this feature can be switched off by de-selecting the corresponding item
from the “View” menu.
If most of the screen should be used for data, not for windows, borders or others, consider the
last 3 options from the “View” menu. Compare the screens in Figure 14 and 15. Here the menu,
toolbar and status bar are switched off. The Menu bar can always be restored by pressing [Ctrl] +
[M].

Figure 15 - “Enlarged” view

Figure 14 - Normal view
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B.14. Analyse – Stroke data
To open the Stroke data window, click the Stroke data button ( ) on the toolbar or select
“Stroke data” from the “Analyse” menu. This enables in-depth analysis of training sessions by
setting any of the 25 recorded parameters on any of the three axes.
Parameters that tend to accumulate during a session, like Time or Distance, result in LineCharts
- as were all charts in previous versions. Parameters that do not accumulate, such as Stroke rate
and Power, are plotted as PointCharts.

Figure 16 - Stroke data window

This chart can get cluttered easily if both Y and Z-axes are used, and a lot of files are loaded. To
get a better overall view, temporarily hide a training session (de-activate it), by un-checking the
check-boxes in the training sessions list. Also, selecting a part of the chart for zooming in can be
very helpful. To do so, click on the chart with the left mouse button, and drag a window from
top-left to bottom-right, and let go of the mouse button.
The data area at the bottom can be copied to the clipboard by right-clicking on it. From there,
it can easily be pasted into a spreadsheet such as MS Excel.
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B.15. Analyse – Force curves
Analysing stroke profiles is done in the Force curves window. To open it, click the Force curves
button ( ) on the toolbar, or select “Force curves” from the “Analyse” menu.

Figure 17 - Force curves window

This window allows one to browse through all force curves in one or more training sessions,
compare them, play one training session as an animation or resize them to ones specific needs
or reference.
At the bottom, the data area is filled with all the parameters calculated for each stroke. This
area is updated automatically when training sessions are (de-)activated and when other force
curves are selected.
A training session is called “Active” when it is checked in the list on the right. A force curve is
called “Active” when it is currently shown in the chart. Therefore, for every training session,
only one can be active.
For a training session, you can either browse through strokes or display the “Session average”.
With the “Square” check-box, the force curve chart is fixed to a square aspect ratio. To have
the chart fill up the entire chart area, un-tick this check-box.
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B.15.1.Force curves – Averages
Besides the “usual” items shown in the training sessions list, there are also four “*Avg.” lines:
1. Active curves. This shows an average force curve based on the current curves visible for the
active training sessions (the ones preceded with a “ticked” check-box).
2. All curves. This shows an average force curve based on all current curves of all training
sessions, regardless of their Active state.
3. All curves in active trainings. An average force curve calculated from all curves in the active
training sessions will be shown if “Avg. 3” is checked.
4. All curves in all trainings. This will result in an average curve calculated from all curves in all
opened training sessions.
Note: For Average force curves, only a limited set of parameters is calculated.

B.15.2.Force curves – Navigate
To navigate through the force curves of a training session, please use the scrollbar or the VCRlike buttons on the right:

First

Previous

Force curve number

Next

Last

Delete force curve

Play, starts animation

Stop, pauses animation
The Play button changes into the Stop button when showing an animation, and changes back to
the Play button when stopped.
Selecting the “Session average” option below the “Browse curves” controls, will show the
average force curve for the selected training session, instead of the current one. As long as the
average is selected, browsing through the force curves for that training session is not possible.
The captions next to the names in the training session list indicate the stroke / force curve
currently shown, for example:
 “Name (213/452)” means the force curve for stroke 213 of a total of 452 is shown.
 “Name [A] (941)” means the average of the force curves for all 941 strokes is shown.
 “Name”, without extras, means there’s no or just one curve in the corresponding training
session, for example in a Stroke file.

B.15.3.Force curves – Scale
To compare force curves of athletes of different strength or height, all shown force curves can
be scaled in height (force) or width (stroke length). To do so, select the “Fixed force” or “Fixed
length” check-boxes. Examples are shown in the following figures:
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normal
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Figure 19 - Force curves, fixed
force 600N

Figure 20 - Force curves, fixed
length 160cm

To save a force curve to a STR file, select the training session in the list and click the Save as…
button ( ) on the toolbar, or choosing “Save as…” from the “File” menu. This STR file can later
be used to serve as a template- or reference-curve for a rowing session.

B.15.4.Force curves – Save
To save a specific force curve, either a “normal” one or an average curve, to disk, click the
corresponding training session in the list. Then, choose “Save as ...” from the “File” menu, or
click the “Save as ...” button ( ) on the toolbar. This will present the “Export stroke file”
dialogue, where an appropriate location and file name can be entered.

B.16. Help - Manual
Selecting this option will launch this manual in a separate window.

B.17. Help - Website
Selecting this option, or clicking the Website button ( ) on the toolbar, launches the default
web-browser on your PC opening the website http://www.rowperfect.com/

B.18. Help – About
Selecting “About” from the “Help” menu, will bring up the About dialogue with the current
version number and a list of people and companies who contributed one way or the other in the
development of Rpw. Clicking on the link to the website will open the default web-browser with
the site provided.
The last page on the Help dialogue contains some statistics on programme use.

B.19. CARE.EXE Reference
At first sight, Rpw may look very different from the DOS based Rowperfect software, CARE.EXE.
There are however, also a series of similarities. The following table lists the features of
CARE.EXE available in Rpw, and where to find them in this manual for more details:
CARE.EXE
User screen



Save (F8)

Rpw
Training window, tab “General” (for the name)
and tab “Workout” for the training session
definition.
Use the Save button ( ) or choose “Save” in the
“File” menu to save the current training session
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See B.2.1 and B.2.2

See B.6 and B.7
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CARE.EXE



Load (F9)





Restore (F10)
Password (F5)
Color (F6)

Work screen
 Quit (Esc)



Evaluate (F1)
Displays (F2)




Strokes (F3)
Reset (F4)




DOS (F5)
User settings (F6)

Evaluation screen
 Set X (F1)
 Set Y (F2)
 Set Z (F3)
 Save (F8)



Load (F9)



Text (F4)

Strokes screen
 Previous ()
 Next ()
 Set (Space)


Save (F8)



Load (F9)
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Rpw
using the same file name. Use the Save as button
( ) or choose “Save as …” from the “File” menu
to use a different name.
Use the Open button ( ) or choose “Open” from
the “File” menu.
Not available.
Not available.
Double click the name in a training sessions list
or click [Options] in the training window, tab
“General”.

Where to find

Row window
Click the Exit button ( ) or choose “Exit” from
the “File” menu.
Stroke data window.
Right click the parameter cells in the bottom
and/or right side of the Row window.
Force curves window.
Click [Disconnect] in the lower left corner of the
Row window.
Not available.
Training window, tab “General” (for the name)
and tab “Workout” for the training session
definition.

See B.11
See B.9

Stroke data window.
Set the X-axis.
Set the Y-axis.
Set the Z-axis.
Use the Save button ( ) or choose “Save” in the
“File” menu to save the current training session
using the same file name. Use the Save as button
( ) or choose “Save as …” from the “File” menu
to use a different name.
Use the Open button ( ) or choose “Open” from
the “File” menu.
Not available.

See
See
See
See
See

Force curves window.
Click the Previous button ( ).
Click the Next button ( ).
Not available. Force curves remain on screen
when navigation is completed.
Use the Save as button ( ) or choose “Save as
…” from the “File” menu to save the current
force curve as a STR file.
Use the Open button ( ) or choose “Open” from
the “File” menu.

See B.15
See B.15
See B.15
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See B.4

See B.1 and B.2.1

See B.14
See B.11
See B.15
See B.11

See B.2.1 and B.2.2

B.14
B.14
B.14
B.14
B.6 and B.7

See B.4

See B.7

See B.4
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B.20. Command Line Parameters
Starting Rpw with Command Line Parameters facilitates selection of the same user file again and
again, alternatively opening the Browse window in the same folder as usual.
Note: Command Line Parameters are optional.
To use Command Line Parameters, make a shortcut to Rpw.EXE, for example on your desktop,
and open its properties page (right click the shortcut and choose “Properties”). Command Line
Parameters are entered in the “Target” box.
Below is a list of all available options:
/?, /H
/N
/D
/F
/R[:UserFile]
/R:?
/X
/X+
/X-

Show this list
Create a new training session
Open stroke data window
Open force curves window
Open row window (with UserFile)
Open row window with “Open user file” dialogue
Register current Rpw file types
Register all Rpw file types
Un-register all Rpw file types

If no parameter is given, Rpw starts with a new Row window by default (parameter “ /R”).
General remarks on parameters:
 Multiple parameters and files are allowed.
 The “/” can be replaced by a “-”.
 Parameters are not case-sensitive.
 Enclose Path and UserFile with quotation marks, especially when they contain spaces.
Example:
 To let Rpw start with a predetermined User file, type the following in the “Target” box:
“C:\Program Files\Rowperfect for Windows\Rpw.exe” /R:“C:\RPData\John-1K.ini”
This example assumes the User file you’d like to be opened automatically is
“C:\RPData\John-1K.ini”.
With the “Run” option in the Properties dialogue, the initial screen size can be set, e.g. select
“Maximised” to let Rpw start in a maximised window.
Note: There’s no limit to the number of shortcuts that can be made to Rpw.
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Frequently Asked Questions

C.1. Connection problems
Q. When connecting to the interface, by closing the “Connect” window, I get an error stating
“Comport : no data”. I’m confident the interface is hooked up properly. What’s going wrong?
A. Rpw sometimes has some trouble in detecting whether the interface is sending data. To
prevent this, give the flywheel a gentle swing when closing the “Connect” dialogue.

C.2. Feature requests
Q. Is there a way to analyse Interval data with Rpw, or compare more than just two training
sessions?
A. Yes and No. These features are not available in Rpw, but they are in another MS Windows
programme for the Rowperfect, called SEAN : Session Analysis. For more information on SEAN,
please contact Row-Ware (website http://www.row-ware.com/sean/ or e-mail info@rowware.com) .

C.3. Save chart colours
Q. Every time I open a new “Row” window, I need to set the chart colour and line type
manually. Can this be saved somehow?
A. When the workout has been set up (name, type, distance / duration etc. are entered),
change to the first tab of the “Training” window, and set the chart options. Then, choose “Save
as” from the “File” menu, and save the user data as an STG file. The next time you open a new
“Row” window, open this file with the [Open] button in the “New row window” dialogue and
save the results under a different file name.

C.4. Use reference curve
Q. How do I set Rpw to use a reference curve in the “Row” window?
A. By default, all curves visible in the “Force curves” window, are used as a reference curve in
the “Row” window. Thus, to use a reference stroke, just open a STR or STG file and - in case of
the STG file – select the appropriate curve to be used as a reference. Then, switch to the “Row”
window (or start a new one) and start rowing.
Right-clicking on the Force curve chart in the “Row” window will show pop-up menu where this
behaviour can be switched off.

C.5. Save a reference curve
Q. How do I scale a previously recorded force curve and save it as a reference for future use?
A. In Rpw, open a stroke profile (STR) file or Training file (STG) and open the “Force curves”
window. Click on the name of the session in the Training sessions list on the right, and browse to
the force curve that you would like to serve as a template for future workouts, by using the VCR
like buttons. Optionally, use the check-boxes Fixed force and/or Fixed length to scale the curve
vertically and/or horizontally. When finished, click the “Save As ...” button on the toolbar ( )
or select “Save As …” from the “File” menu, and save the STR file (see also B.15.4).
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C.6. Old computer hangs during long sessions
Q. My old laptop seems to hang when doing long sessions with Rpw. Can anything be done about
it?
A. Long sessions means accumulating lots of data. As Rpw stores all parameters of all strokes in
a session, after 20 minutes (or even less, depending on computer hardware) the PC can run out
of memory and processor power. There are 2 ways to prevent this to happen, aside from the
obvious "don't do long sessions" :-)
1. Switch of the Stroke data chart in the Row window, by right-clicking it.
2. Add a line to the RPW.INI file limiting the number of strokes visible in this chart (see also
“Performance issues” in B.11). All data will still be stored, but only the last x strokes will
be visible during the session.

C.7. Using Rpw without a serial port
Q. Can I use Rpw on a PC without a serial port?
A. In general, Rpw can connect to the Rowperfect PC Interface through a so called USB serial
adapter. However, not all cables tested have proven to work properly, depending on brand, MS
Windows version and computer hardware. Contact us for more details.
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